Перенос минус-слов из Adwords в Директ

Перенос минус-слов из Adwords в Директ
Евгений Юдин

Вчера выложил макрос для переноса минус-слов из Директа в Adwords. Поступил резонный вопрос — а обратно как?

Вот вчерашний пост с макросом: Excel макрос для переноса минус-слов из Директа в Adwords

Дано:

В первом столбце названия групп объявлений. Во втором — минус-слова.

В третьем столбце в первую ячейку копируем минус-слово из второго столбца.
В последующие ячейки 3-го столбца вставляем и растягиваем формулу:
=ЕСЛИ(A2=A1;B2&» -«&C1;B2)
 
В четвертом столбце везде вставляем и растягиваем формулу:
=ЕСЛИ(И(D2<>»»;A1=A2);D2;C1)
 
Должно получиться примерно так:
Копируем четвертый столбец и вставляем только значения (если не знаешь как, смотри пост про макрос для эксель в начале статьи).
Оставляем эти значения и первый столбец. Второй и третий столбец удаляем.
На вкладке «данные» жмем «удалить дубликаты».
 
Осталось справа от минус-слов в столбце вставить и растянуть формулу:
=A1&» -«&B1
Готово. В первом столбце у нас названия групп, а в крайнем правом — фразы с минус-словами.

0 Комментариев

Оставить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

*

0
0